Cisco CCNA Exam 2

1. You have been assigned a 10.200.30.0 /24 subnet. The requirement is to connect two routers directly and assign IP addresses to interfaces connecting both the routers. Which subnet can be used to connect two routers to reduce wastage of IP addresses?

2. You have configured a DHCP scope on the Cisco router in your network. The laptops are not able to get an IP address. You ran DHCP debug command on the router and noticed following logs entries

What could be the issue?

 

3. Examine the following output of a command from a Cisco switch

Which three commands related to port security are configured under the interface GigabitEthernet 0/0?

4. Which of the following are some of the benefits provided by RIP version 2 over RIP?

5. You ran the following command on Cisco switch and got the below output

Switch#show lldp neighbors
% LLDP is not enabled

Which command is used to enable The Link Layer Discovery Protocol on a Cisco IOS device?

6. Which command provides the following output?

7. The Spanning Tree Protocol (STP) is used to prevent network loops while permitting redundancy to the network

8. Static routes are configured in the router by using a routing protocol

9. Which multicast address is used by EIGRP, as the destination address for periodic updates?

10. You have configured OSPF between two routers but they are not able to form a neighbour relationship. On one of the routers, you get below message under the logs

%OSPF-4-ERRRCV: Received invalid packet: mismatched area ID, from backbone area must be virtual-link but not found from 192.168.10.6, GigabitEthernet0/0

What could be preventing them from forming adjacency?

11. Match the command with its usage
show interfaces
Used to see layer 1 statistics of the interfaces

Unselect

Used to see the IP addresses configured on the interfaces

Unselect

Used to see IP addresses and layer 2 information configured on the interfaces

Unselect

show controllers
Used to see layer 1 statistics of the interfaces

Unselect

Used to see the IP addresses configured on the interfaces

Unselect

Used to see IP addresses and layer 2 information configured on the interfaces

Unselect

show ip interface
Used to see layer 1 statistics of the interfaces

Unselect

Used to see the IP addresses configured on the interfaces

Unselect

Used to see IP addresses and layer 2 information configured on the interfaces

Unselect

12. Rapid PVST+ has three port states while Spanning Tree Protocol (STP) has five. Which state is introduced by Rapid PVST+, that isn't used in STP?

13. Examine the Cisco switch interface configuration below

Switch#show run interface gigabitEthernet 0/0
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk

What is the function of the command 'switchport trunk native vlan 10' ?

14. What are some of the benefits of using VLANs in a network?

15. Which two commands can not be used to verify a trunk port configuration on a Cisco switch interface?

16. Switches dynamically learn MAC addresses based on the broadcast addresses that it sees

17. You have configured the following commands under an interface GigabitEthernet0/0 on a Cisco router.

R1#show run interface gigabitEthernet 0/0
interface GigabitEthernet0/0
ip address 192.168.10.5 255.255.255.252
ipv6 address autoconfig
end

Which commands you can use to show the IPv6 address assigned via stateless autoconfiguration?

18. What are the two ways to compress an IPv6 address?

19. In the Internet Protocol Version 6 (IPv6), which address block is reserved for link-local unicast addressing?

20. Which of the following statements are not true about NAT?

21. Which of the following Cisco IOS commands can be used to troubleshoot the connectivity issues?

22. You have configured a Cisco router and want to secure it by preventing non-SSH connections. You have configured virtual terminal ports as shown below

line vty 0 4
password 7 120D001A025A5E576A
login

Which command is used under virtual terminal ports, to limit the router to SSH connections only?

23. Which of the following OSPF related requirements should be met by two routers to form an adjacency?

24. Only one OSPF process can be configured on a Cisco router

25. SNMP is an application-layer protocol framework and used for the monitoring and management of devices in a network. Which of the following are parts of the SNMP framework?

26. You have configured VRRP between two routers as shown below

R1(config)#int gig0/0
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# vrrp 100 ip 192.168.10.254
R1(config-if)# vrrp 100 priority 100

R2(config)#int gig0/0
R2(config-if)# ip address 192.168.10.2 255.255.255.0
R2(config-if)# vrrp 100 ip 192.168.10.254
R2(config-if)# vrrp 100 priority 90

Which router would become a master and why?

27. Examine the following configuration and a show command output

R1#sh run int gi0/0

interface GigabitEthernet0/0
ip address 192.168.10.5 255.255.255.252
ip access-group MGMT in

R1#sh access-lists MGMT
Extended IP access list MGMT
10 permit tcp any any eq telnet
20 deny tcp any any eq 22
30 permit ip any any

You are not able to connect to the router via an SSH session. What command would the fix issue?

28. Which command will convert all the dynamic secure MAC addresses to sticky secure MAC addresses on a Cisco switch?

29. Which of the following encryption algorithms is used by WPA2?

30. Infrastructure mode is a wireless topology, which involves having the wireless clients connect to an access point

31. Match the CIDR notation with correct subnet mask
/32
255.255.255.224

Unselect

255.2555.255.252

Unselect

255.255.255.255

Unselect

255.255.255.248

Unselect

/30
255.255.255.224

Unselect

255.2555.255.252

Unselect

255.255.255.255

Unselect

255.255.255.248

Unselect

/29
255.255.255.224

Unselect

255.2555.255.252

Unselect

255.255.255.255

Unselect

255.255.255.248

Unselect

/27
255.255.255.224

Unselect

255.2555.255.252

Unselect

255.255.255.255

Unselect

255.255.255.248

Unselect

32. Which statements are true about extended access control lists?

33. Which protocol runs between a Cisco WLAN controller and lightweight access points to route packets in and out of the WLC?

34. Which command provides the following output?

 

35. You have configured an EtherChannel using below command

interface GigabitEthernet1/0/3
switchport access vlan 30
switchport mode access
channel-protocol lacp
channel-group 1 mode active

What does channel mode 'active' means?

36. Which of the following statements are true about Open Shortest Path First (OSPFv2) version 2?

37. What are the few differences between the Link Aggregation Control Protocol (LACP) and Port Aggregation Protocol (PAgP)?

38. Which Cisco IOS command finds the path a packet takes while being transmitted to a remote destination?

39. A router is running three routing protocols named OSPF, RIPv2 and EIGP with default administrative distance (AD) values and as a result, has learned three routes to 10.230.20.0 network. Which route would be prefered by the router?

40. Examine the following output from a Cisco switch

switch#show mac address-table dynamic
Mac Address Table
-------------------------------------------
Vlan Mac Address Type Ports
---- ----------- -------- -----
30 0000.5e00.011e DYNAMIC Po5
30 0000.5e00.01dc DYNAMIC Po5
30 0000.5e00.01dd DYNAMIC Po6
30 0009.0f09.5a0d DYNAMIC Gi1/0/1

How the switch will handle a frame with source MAC address  '0000.5e00.011e' and destination MAC address '0009.0f09.5a0d '?

41. A switch will forward a frame out all the ports except the one on which it arrived, if there is no destination entry for this frame in the MAC address table

42. What is the effect of the below command under the switch interface?

switch(config)#int gi1/0/25
switch(config-if)#spanning-tree portfast

43. Which wireless AP mode is used for a remote office to serve wireless clients even if the remote office access points lose connection to the Cisco WLC located at the main office?

44. Which settings are optional when configuring a new Cisco Wireless LAN Controller via GUI?

45. Examine the output below

Router#show ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 121.1.42.175:22 192.168.1.1:22 139.161.121.110:47876 139.162.121.110:47876
tcp 121.1.42.175:5062 192.168.1.2:5062 139.161.121.110:51690 139.162.121.110:51690

Which IP address is the source IP in the above output after NAT translation is done?

 

46. Match the DHCP commands with its function
ip dhcp client request
To acquire the IP address for an ethernet interface

Unselect

Allows the router to forward local DHCP requests to one or more remote DHCP server

Unselect

Defines a DHCP scope and specifies the various DHCP options the router will assign to clients

Unselect

This command allows to turn off some of the requested DHCP options

Unselect

ip helper-address
To acquire the IP address for an ethernet interface

Unselect

Allows the router to forward local DHCP requests to one or more remote DHCP server

Unselect

Defines a DHCP scope and specifies the various DHCP options the router will assign to clients

Unselect

This command allows to turn off some of the requested DHCP options

Unselect

ip dhcp pool
To acquire the IP address for an ethernet interface

Unselect

Allows the router to forward local DHCP requests to one or more remote DHCP server

Unselect

Defines a DHCP scope and specifies the various DHCP options the router will assign to clients

Unselect

This command allows to turn off some of the requested DHCP options

Unselect

ip address dhcp
To acquire the IP address for an ethernet interface

Unselect

Allows the router to forward local DHCP requests to one or more remote DHCP server

Unselect

Defines a DHCP scope and specifies the various DHCP options the router will assign to clients

Unselect

This command allows to turn off some of the requested DHCP options

Unselect

47. Examine the following output of a Cisco IOS command

R2(config)#crypto key generate rsa
The name for the keys will be: R2.R2.local
Choose the size of the key modulus in the range of 360 to 4096 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]:
% Generating 512 bit RSA keys, keys will be non-exportable...
[OK] (elapsed time was 1 seconds)

Which statements are true about above command?

 

 

48. How network automation impacts network management?

49. Which of the following are southbound APIs

50. Ansible playbook is written is YAML language and it lists the tasks to be executed by ansible


 

Leave a comment